WI Developer

Portal de Desenvolvedores WebInside

Seja bem-vindo, Visitante
Por Favor Entrar ou Registrar.    Esqueceu a senha?

Acentuações estranhas no WI após instalação
(1 visualizando) (1) Convidado
Ir para baixoPágina1
TóPICO: Acentuações estranhas no WI após instalação
#4
Acentuações estranhas no WI após instalação 8 Anos, 8 Meses atrás Popularidade: 1  
Após instalar um WI num Debian 5.0, o aplicativo está com carateres estranhos na interface.
Veja imagem.
aurelio (Admin)
Administrator
Mensagens: 38
graph
Usuários Offline Clique aqui para ver o perfil deste usuário
Última Edição: 2009/10/30 17:09 Por aurelio.
O administrador desabilitou acesso publico para escrita.
 
#5
Re:Acentuações estranas no WI após instalação 8 Anos, 8 Meses atrás Popularidade: 1  
Dica de Marcelo para ver o locale usado pelo WI (so deve ser "en" ou "pt_BR")


<%@ page import="java.util.*"%>
<html>
<body>
<%=Locale.getDefault()%>
</body>
</html>
aurelio (Admin)
Administrator
Mensagens: 38
graph
Usuários Offline Clique aqui para ver o perfil deste usuário
O administrador desabilitou acesso publico para escrita.
 
#6
Re:Acentuações estranas no WI após instalação 8 Anos, 8 Meses atrás Popularidade: 1  
Solução (Debian 5):

Editar o /etc/profile e inserir no final:
export LANG=pt_BR.ISO-8859-1
export LC_ALL=pt_BR

Reiniciar o linux.
aurelio (Admin)
Administrator
Mensagens: 38
graph
Usuários Offline Clique aqui para ver o perfil deste usuário
Última Edição: 2009/09/24 09:28 Por aurelio.
O administrador desabilitou acesso publico para escrita.
 
#41
Re:Acentuações estranas no WI após instalação 8 Anos, 2 Meses atrás Popularidade: 1  
No Ubuntu:

Edite o catalina.sh:

No inicio do codigo (apos os comentarios):
export LC_ALL="pt_BR.ISO8859-1"
CATALINA_OPTS="-Dfile.encoding=ISO-8859-1 -Duser.language=pt -Duser.region=BR -Djava.awt.headless=true"

Reinicie o serviço.
aurelio (Admin)
Administrator
Mensagens: 38
graph
Usuários Offline Clique aqui para ver o perfil deste usuário
Última Edição: 2014/03/31 10:02 Por aurelio.
O administrador desabilitou acesso publico para escrita.
 
#87
Re:Acentuações estranhas no WI após instalação 3 Anos, 8 Meses atrás Popularidade: 0  
Prezados,
outro modo de resolver o problema da acentuacao, no CentOS release 6.3 (Final),
e quando o Tomcat foi instalado pelo pessoal da infraestrutura e
nao tem o arquivo catalina.sh:

1 - localize o arquivo tomcat.conf com o comando, a partir do diretorio root \ :
find / -name tomcat6.conf

2 - vai aparecer algo como:
/etc/tomcat6/tomcat6.conf

3 - abra esse arquivo e localize a linha:
JAVA_OPTS="${JAVA_OPTS} -Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory"

4 - acrescente nessa linha a dica do colega acima, ela ficara :
JAVA_OPTS="${JAVA_OPTS} -Djavax.sql.DataSource.Factory=org.apache.commons.dbcp.BasicDataSourceFactory -Dfile.encoding=ISO-8859-1 -Duser.language=pt -Duser.region=BR -Djava.awt.headless=true"

5 - reinicie, so o tomcat:
service tomcat6 restart

6 - pronto o WI vai funcionar, legal com acento e tudo.
jorge.abilio (Usuário)
Fresh Boarder
Mensagens: 1
graphgraph
Usuários Offline Clique aqui para ver o perfil deste usuário
O administrador desabilitou acesso publico para escrita.
 
Ir para cimaPágina1
 
Joomla 1.5 Templates by Joomlashack